Sun E450

Live forum: /viewtopic.php?t=185


17-11-2005 10:37:51

I was curious if anybody around here has installed linux on a Sun machine? I'm currently working with Gentoo on a E450, I am now trying to configure X.

Other than that, everything seems to be going fine. I'll post the kernel config and X config once I have a chance.


17-11-2005 12:16:57

Yes I have. Sun IPC and a Sparc Station 4. I have tried on a Ultra 1 without success so far. Distros RH 6.2 (When they had a sparc version) and Aurora.

I have tried Gentoo on sparc but was generally uncessful. The Sparc 4 seemed to run into a memory problem and my Ultra 1 just doesn't have enough space.

I have also gotten the Sun Javastations working as well. They rely more on a NFS boot and are a bit of a pain to setup. No X running though.


17-11-2005 12:26:05

I've followed the instructions to install Gentoo on a Sparc5 which currently does nothing for me.


17-11-2005 16:01:46

I have a lot of Suns running Linux:
- 1 x Javastation I "Mr. Coffee" (Debian)
- 2 x Sparc 20 (Debian)
- 1 x Sparc 10 (Debian)
- 1 x Ultra 1 (Debian)
- 1 x Ultra 5 (Hardened Gentoo)
- 1 x Ultra 10 (Debian)
- 1 x Blade 100 (Debian)
- 1 x E250 (Debian)

I have a couple of other ones that don't run Linux:
- 1 x Javastation II "Krups" (NetBSD)
- 1 x Blade 100 (Solaris 9)
- 1 x Blade 1000 (Solaris 10)

My E250 is closest in HW terms to your E450, but it doesn't have a videocard so no X there.

Overall, most of them run Linux quite nicely. Every once and a while I run across some weird issue (LVM, iptables logging system, kb issues with the Blade 100), but for the most part it's been straightforward. The old ones definitely run current versions of Linux much more nicely than any of the last 3 versions of Solaris... ;-)

- Colleen


17-11-2005 16:12:23

Colleen, what in the world do you do with all those machines?


18-11-2005 08:31:03

Well I was finally able to bring up X ... but then it froze soon after.

Colleen, I am assuming that you have configured Xorg with using the Sun keyboard and mouse, type 5c I believe. Could you post those two sections?


18-11-2005 08:43:14

Central heating.


19-11-2005 13:51:34

Here's that part of the config from my Ultra 10. Relevant info: PGX24 graphics, 2.6.14 kernel (Debian unstable), Xorg 6.8.2 (Debian unstable), Sun Type 6 (US/UNIX) keyboard (mini-DIN connector), Sun Crossbow mouse (mini-DIN connector).

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc102"
Option "XkbLayout" "us"

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "false"

It's important to note that a config for a 2.4 kernel would be completely different. The 2.6 kernel maps everything to PC keycodes, which is why the XkbModel is "pc102" here, and the mouse protocol is "ImPS/2". That means you need to have both X and console settings configured to use the kernel keymap. This was a real lifesaver for me, because the type 6 keyboards never really worked right until this change. AFAIK it should be the same for your Type 5, but I think I got rid of all mine because I can't find one to test with. :-\

When you say that it "froze", what exactly happened, and at what point?

As far as what I do with them, well...
- Sparc 10s: testing Debian installer and kernel versions on sun4m
- Sparc 20: shell server
- Javastations: experimentation. In a dream world I'd be able to have my Krups in the kitchen and use it as a little X terminal, but the problem is that X doesn't work on it under anything but the heinous JavaOS. Maybe someday...
- Ultra 1: DHCP/DNS/RARP/TFTP server
- Ultra 5: experimentation on sun4u; last experiment was the hardened Gentoo
- Ultra 10: dual-boot Solaris 9/Debian desktop, but the poor thing only has 128 MB RAM :-(
- Blade 100: humility. Seriously, for a machine that's the closest thing Sun ever made to a beige box, it's a real pita to get working 100% in Linux.
- Blade 1000: beast of a Solaris 10 desktop
- E250: NFS file server

Dan: I use the 4 P4 boxes for the central heating. :P With the exception of the Blade 1000, the Sun's don't generate a lot of heat (maybe calling them "Suns" is a bit of a misnomer, lol).

- Colleen


22-12-2005 14:00:13

I've installed some form of linux or other on 1 or more of the following:

Sparc Classic
Sparc IPX
Sparc LX
SparcStation 1+
SparcStation 10
SparcStation 20
Ultra 2
Ultra 5

On the E450 I never did get X working properly. Other than that it worked great. Did you get yours sorted in X? If so, would you mind posting the config for me?


23-12-2005 09:18:43

I was going to attach the conf file but I guess that has been disabled.

So you can get it at

The keyboard is what I had problems with. According to some Gentoo guys though, the problem lies in the kernel. I can only use 2.4 with X. Supposedly kernel developers are working on the problems in the 2.6 kernel.


17-01-2006 21:33:44

On one of my ultra5s I have to unplug the keyboard and plug it back in after X starts. Sometimes the mouse, too.

Anyhow, thanks for the info.


18-01-2006 08:26:52

Lets see your x config file, probably something missing in there.


06-02-2006 21:37:00

I'll see if I still have it; haven't booted up the box in a while. Will post it here or a link to it if I have it somewhere.

For what it's worth, our test crux sparc64 releases used kernel 2.6.7 and xorg 6.8.x. (1 or 2, I think). *edit* - it's 6.8.2.


09-02-2006 13:37:04

So... er... I powered up my ultra5 today to find that it doesn't have a hard drive in it anymore. Not sure what's up with that.