MythTV Installfest?

Live forum: /viewtopic.php?t=109


03-03-2005 14:58:27

Everyone needs a PVR. I don't even watch TV and I need one! Whats everyone's opinion?


03-03-2005 16:01:38

I would be happy to help out with getting people up and running with Mythtv, I know I have a lot of people interested in setting up a MythTV box.




03-03-2005 16:14:47

Also, for those of you who might already have a mythTV box up and running, you might want to check out my forums at I have some helpful mods for nuvexport and a short synopsis on flagging commercials with mythTV.

nuvexport by the way is a program to put your mythtv recorded TV shows into different formats like divx (what I use) or VCD (among others).

Hope it helps.

P.S. You don't need a beefy box to just record shows, but it is helpful if you plan on using nuvexport. My AMD XP 2500+ (Barton core) proc takes about a third of the time to transcode (using nuvexport), as it does to record the show, to give some perspective. (example: 30 min show takes 10 min to transcode with commercials removed)


04-03-2005 12:48:14

Interesting.... This is one that would take some preplanning and work but could be done. The main problem may be in the many ways you can use and setup Myth along with the meriad of hardware availble.

But if there is enough interest for it I am not adverse to giving it a shot.


08-04-2005 09:27:20

wolfie, what version of mythtv and which flavor of linux are you running? I've experimented with a few different setups so far (crux, fedora, debian) and no matter what I set up, the backend crashes all the time.

The only shows I watch are Alias, Lost, 24, and sometimes a movie here and there, so it's basically only got weekly schedules. If I'm not watching it or I forget, it will crash without fail before the next week's recordings. Also, if I enable commercial flagging in the setup, it crashes EVERY time commercial flagging starts. I leave that disabled and just do it from the command-line if I need them taken out.

When it hasn't crashed, my recordings are fine. No problems with viewing or editing, etc.


For what it's worth, my hardware is an Intel P3 @ 833 with 384M RAM, PVR350 capture card.


08-04-2005 13:06:28

jaeger which version of the ivtv drivers are you using? Also are you doing any of the On Screen Display stuff throught the PVR350?

I currently lurk on the ivtv-devel list and there have been some problems like this recently.


08-04-2005 13:40:57

At this time I'm using ivtv 0.2.0-rc3i from Chris Kennedy's site. I've also tried the last 2 0.2.0 revisions and 0.1.0-pre2-ck104y and a couple other revisions of ck10X. The problem is the same regardless of version. The constant in this case is firmware 22037. I guess I need to try different firmwares and see if that helps.

I'm not using the pvr350's decoding or tv-out at all. I've got a PCI Geforce4MX in the machine (it's a desktop form factor dell box with no AGP slot).

Some things I need to try, probably:

enabling/disabling renderaccel in the xorg.conf
opengl vsync

Snooping on the mailing lists turns up mentions of these every now and then but I haven't experimented with them yet as I prefer to break/change 1 thing at a time, hehe...


08-04-2005 13:41:36

Pfft, forum logged me out.


08-04-2005 14:47:25

Well, I run mythtv on a Gentoo box that has a Hauppage WinTV FM Tuner card. Stats are AMD XP 2500+ Barton Core 160GB with 512MB RAM.

Running mythtv-0.16 from the ebuild ( I have ran from a custom build and also from cvs on this machine with great success.)

Commercial flagging works great and so does nuvexport. I use nuvexport to convert the modified nupple to DivX with no commercials.

Has been pretty rock solid for a while now. The earlier builds, however, I cannot say the same. Also make sure, if running a 2.4 kernel at least, that you turn off premption, (not sure about 2.6). This would hard lock the box every day. :(


08-04-2005 15:45:26

Well, I've never had a problem with hard locks, only the backend crashing, but preemption is another thing I can certainly test easily. I turn it on by default since it's never given me trouble before but worth a shot. I'm running CRUX 2.0, MythTV 0.17, kernel (tried a myriad of different versions but all 2.6, haven't used a 2.4 in ages and don't intend to go back, hehe).

Nuvexport has never given me trouble, either, it works great when I do use it. If I run mythcommflag from the command-line I can even use the cutlist without any trouble. It's just the backend crashes driving me nuts.

I've used MythTV since 0.13 with varying levels of success. 0.16 was the only one that was ever close to rock solid for me and it suffered from the same backend crash issues.


08-04-2005 21:12:07

I am a little suspect of the optimizations if any and the version of gcc you have. Are you compiling from scratch, or installing via some package manager. You might want to try building it from scratch and see what happens and look at the optimizations you are throwing at it.


09-04-2005 23:46:24

I'm using my own CRUX ports for it, found here:

The optimizations used are "-O2 -march=i686 -pipe" and nothing else. I have also tried unsetting them with no changes. The ports system in CRUX builds from scratch and then installs the resulting package, so it's a bit of both in that regard.


11-04-2005 11:32:48

Well, not sure what the deal is.......


12-04-2005 10:05:48

I suppose that's what I expected, in the end, heh. Thanks for trying, at least. I'll poke at it again on different hardware and see what I come up with. Gonna try a few things like disabling the preemptive kernel, etc.


13-04-2005 08:51:10

I just converted my box over to a 2.6 kernel (no easy task for me since I have a root lvm :( ) but anyway, I noticed when I was watching live (so to speak, since it buffers 6 seconds) It was getting real jittery. Have you experienced this? I consequently turned off preemption, but I don't think it made much of a difference. I haven't checked whether the opengl-update nvidia fixed this yet, but I suspect no.

[Thinking out Loud]

Could it be that since I am still running my lvm as lvm 1 and haven't converted the metadata to lvm2 that this is the performance hit?

Could it be that dma is no longer set on the drives? (Playback of prerecorded stuff works fine even when still in the modified nupple format (ie big ass file)

Well, I guess I need to check these things out and make sure. :)

[/Thinking out Loud]


13-04-2005 09:10:57

I've no personal experience with lvm but it sounds like the things you've mentioned would be good things to test. :)


13-04-2005 11:36:07

I use lvm2 on my 2.6 kernel system (but not with Gentoo since I had so many problems with it), and I think it still uses DMA. I can't tell a difference in performance, but I'm not doing anything quite as cool as you guys are...


14-04-2005 13:45:05

Found it........

Looks like for some reason dma is turned off on my hard drives. Going to have to delve into the kernel or rebuild some tools. Looks like my hunch was correct.....

This is becoming annoying.....:(


14-04-2005 14:08:26

You might be able to turn on DMA with hdparm if you don't want to recompile your kernel. That said, of course you'd need the correct kernel support, otherwise it's inevitable. If you're not familiar with hdparm, try hdparm -d 1 /dev/hdX.


14-04-2005 18:40:01

Yeah, I am familiar with hdparm and have already tried it :(, it fails with an nice little error message.......

I am either missing something in the kernel or need to recompile some utilities.


15-04-2005 10:41:36

Well looks like I forgot to add DMA support for my nVidia IDE Chipset....oops....but at any rate it is fixed now. Also with the 2.6 kernel gentoo made a small little tweak when running the backend. They give you the opportunity to turn up the priority of mythbackend. This is really important for smoothing the last little kinks with my upgrade. They recommend nicing the daemon to a might want to try this jaeger and see if your backend stops crashing....